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Release Notification of DS Agile Studio v5.1

DS Agile Studio™ (also known as DSAS, pronounced D-sass) v5.1 is the latest version of the single and unified configuration tool
for GE Vernova’s Grid Solutions Substation Automation Gateways and RTU products. It includes MCP Studio for the G100, G500
and D400 Gateway devices and D2x Studio for the D20/D200, D20MX, D25, and iBox series of RTU and Substation Controllers.

DS Agile Studio version 5.1 encompasses all the features of the following software products:

e DS Agile Studio 5.x, 4.x, 3.x, 2.x and 1.x (NOTE: DSAS 5.1 can upgrade (replace) or be installed side-by-side with these
versions)

e SGConfig 11.1 and prior, ConfigPro 7 and prior

DS Agile Studio v5.1 Changelog

NOTE: The DS Agile Studio Release Notes can always be viewed in DSAS after installing the tool. Look for the Getting Started
section, right below Recent Projects on the Start Page. In Release Notes, look under the Modification History section for
previous versions.
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DS Agile Studio v5.1 Enhancements

e Added support for re-importing SCL files in the IEC 61850 Loader for MCP devices.
e Add support for G100/G500 v5.1 devices
e Added support for up to 20 serial ports in D2x Apps

DS Agile Studio v5.1 Resolved Issues

e Fixed issue where it was not possible to change the redundancy mode of D400 devices from Hot-Standby.
e Fixed issue where the LogicLinx logic in a G500-D2x imported device was not accessible.
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Release Notes

Supported Operating Systems:
Microsoft™ Windows 11 64-bit Professional, Enterprise with 8 GB RAM.
Microsoft™ Windows 10 64-bit Professional, Enterprise and Ultimate with 8 GB RAM.
Microsoft™ Windows Server 2019 with 8 GB RAM.

NOTE: G500, G100, and D400 v5.40 editors only install on 64-bit operating systems
NOTE: Support for and Testing on Windows 7 ended with DSAS v3.0

For a complete compatibility matrix, go to the DS Agile Studio folder on the SAS Technical Support website (login required) at
http://sc.ge.com/*SASTechSupport

Support is not provided for versions of this product that are installed on operating systems other than those identified above, as
the operation of this product has not been verified for any other combinations of operating systems.

Release Information

ISO File DSAgileStudio_5.1.0.46181.iso
SHA256 a4398ae9e7034f01810d9d197ae77d901794¢c510618541123b268bc00119cb28

MD5SUM 36b584b42d4e16820bf91ef35593¢c49d

Installer File = SetupDSAgileStudio.exe
SHA256 c6395a93abece4d43aaldd01a910dd2f249f6193alce4355dd5abf908e7e00d4

MD5SUM 7cb6b14b073366b3ed57284822f12f37

DSAS Install Procedure

Please download the DS Agile Studio ISO file, mount the .iso file as a drive, run the SetupDSAgileStudio.exe file and use the File
System Install option to install DSAS.

Due to a change in GE Vernova cyber security policies, the DS Agile Studio Web Install no longer works outside of the
GE Vernova network. We apologize for any inconvenience.

A DS Agile Studio 4.0.0.44747 Setup

Prerequisites Folder
Select folder where setup will get the prerequisites files ...

() web-based install

(®) File system install
Prerequisites folder:

b: \Prerequisites

(O 150 file install
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Additional Information about the IEC 61850 Loader support for re-importing SCL files

DSAS v5.1 introduces support for re-importing SCL files (.scd, .cid, .icd, .iid) in the IEC 61850 Loader for MCP devices. This
means that new versions of SCL files can be used to update the configuration of IEC 61850 Client configurations in IEC 61850
Loader, subject to certain rules.

“Re-import operation” means that new versions of SCL files associated with the same previously configured (“imported”)
Servers (same Device Type and Device Name) can be used to update the configuration of IEC 61850 Client in IEC 61850 Loader,
subject to below rules.

1.  SCL re-import can be performed on MCP devices (minimum firmware v2.5) with IEC 61850 Client in Ed1/Ed2 mode
(displayed in the title bar of IEC 61850 Loader).

2. Re-import can be performed only for devices with same PhysicalDeviceName as when was first imported (created).
3. SCL files can be re-imported in one of two ways:

a. CID, ICD, and IID files can be re-imported by right clicking on the corresponding device in IEC 61850 Loader
and choosing the Re-import option. The IEC 61850 Loader then prompts to select the new SCL file (.cid, .icd,
.iid) for that device if it contains the same PhysicalDeviceName.

T | ~ Bayl

B] Properties F&50V620
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Edit Configuration

x Delete

" Re-import I}

Properties
Edit Configuration

Delete

Re-import %
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b. SCD files can be re-imported by right clicking on the Bay and choosing the Re-import option. The IEC 61850
Loader then prompts to select the new SCD file, evaluates for IEDs that are in the bay in the new SCD file, and
prompts to choose which IED(s) to re-import. Only previously instantiated IEDs in the selected Bay which are
found in the new SCL file are allowed to be re-imported. For e.g. — if the same SCD file contains multiple IEDs in
different bays, the re-import operation will have to be performed on each bay, for those specific IEDs part of
same SCD file but across bays.

Properties

Delete

Add Server

Add D25

Re-import I}
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4. Only previously mapped points (selected in the tree) are assessed for changes after re-import of the new SCL file.

Re-import operations will retain the database links for the previously mapped points as long as the DataModel in the
new SCL file still contains the previously mapped points and any potential changes in the new SCL file follow the “Yes”
result in the table below

BRYDEVNENE [Datacct| LDName / ENPESEIR | LClass | LNInst | S

Re-import with retaining DB links
PhyDevName DataSet LDName LNPrefix LNClass LNInst DAO is possible Notes
Same Same Same Same Same Same Same Yes SCD/CID/ID ok.

SCD/CIDAID ok.

Requires user to first Rename the Existing IED Name in Loader
Changed Same Same Same Same Same Same Yes to match new name in SCL file - and then do the re-import.
SCD/CID/IID ok.

May require configuration of Dynamic DataSet(s) if the
previously mapped data is still in the data model but no longer

Same Changed Same Same Same Same Same Yes in any configured dataset.
Same Same Changed Same Same Same Same No
Same Same Same Changed Same Same Same No
Same Same Same Same Changed Same Same No
Same Same Same Same Same Changed Same No
Same Same Same Same Same Same Changed No

6. Re-import operations will remove the previously mapped points from the database if the new SCL file changed the
DataModel in a way that impacts previously mapped points according to the “No” result in the table above.

7. The re-import operation will inform user if previously mapped points have been removed from the DataSet but are still
part of the DataModel in the new SCL file; these previously mapped points will still be present in the database (but not
in the DataSet Tree).

20 paints previously mapped in this IED are no longer assigned to a dataset configured for paolling or reparting after
this operation.

These paints will be offline unless you assign them to a dataset configured for polling or reporting.

Please examine the re-import log for more details.

oK Show Log

Log example:

2025-01-15 15:26:32.6165 - WARN: The following previously mapped point(s) for IED
Test 2 are no longer assigned to a dataset for retrieval by polling or reporting after
the Loader re-import operation.

These points will be offline unless you assign them to a dataset configured for polling
or reporting.

2025-01-15 15:26:32.6165 - WARN:
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2025-01-15 15:26:32.6165 - WARN: HomeDirectory=S000001,Point ID=409,Point Name=GGIOl
Indication 1,Point Reference=Test 2.Master/.GGIO.1l.Indl.stVal[ST].0,Point
Type=DigitalInput

2025-01-15 15:26:32.6165 - WARN: HomeDirectory=S000001,Point ID=200,Point Name=Phase A
THD, Point Reference:Test_Z.Meter/Jl.MHAI.l.ThdA.phsA.cVal.mag.f[MX].O,Point
Type=AnalogInput

2025-01-15 15:26:32.6165 - WARN: HomeDirectory=S000001,Point ID=202,Point Name=Phase C
THD, Point Reference=Test 2.Meter/Jl1.MHAI.l.ThdA.phsC.cVal.mag.f[MX].0,Point
Type=AnalogInput

2025-01-15 15:26:32.6165 - WARN: HomeDirectory=S000001,Point ID=248,Point
Name=Vab, Point Reference:Test_Z.Meter/.MMXU.l.PPV.phsAB.cVal.ang.f[MX].O,Point
Type=AnalogInput

2025-01-15 15:26:32.6310 - WARN: HomeDirectory=S000001,Point ID=249,Point
Name=Vab, Point Reference=Test 2.Meter/.MMXU.l.PPV.phsAB.cVal.mag.f[MX].0,Point
Type=AnalogInput

2025-01-15 15:26:32.6310 - WARN: HomeDirectory=S000001,Point ID=250,Point
Name=Vab, Point Reference=Test 2.Meter/.MMXU.l.PPV.phsAB.instCVal.ang.f[MX].0,Point
Type=AnalogInput

2025-01-15 15:26:32.6310 - WARN: HomeDirectory=S000001,Point ID=251,Point
Name=Vab, Point Reference=Test 2.Meter/.MMXU.1l.PPV.phsAB.instCVal.mag.f[MX].0,Point
Type=AnalogInput

2025-01-15 15:26:32.6310 - WARN: HomeDirectory=S000001,Point ID=252,Point
Name=Vab, Point Reference=Test 2.Meter/.MMXU.1l.PPV.phsAB.range[MX].0,Point
Type=AnalogInput

2025-01-15 15:26:32.6310 - WARN: HomeDirectory=S000001,Point ID=253,Point
Name=Vbc, Point Reference=Test 2.Meter/.MMXU.1l.PPV.phsBC.cVal.ang.f[MX].0,Point
Type=AnalogInput

8. The re-import operation will inform user if previously mapped points have been removed from the DataModel in the new
SCL file; these previously mapped points will no longer be present in the database.

2 points previously mapped in this IED were removed during this operation because they no longer exist in the data
model of the IED.

If these points were referenced in another application, they will no longer be available to that application.

Please examine the re-mport log for more details.,

Ok Shaow Log

Log example:

2025-01-15 11:05:24.7475 - WARN: The following previously mapped point(s) for IED
TESTDEVICE GOl were removed during the Loader re-import operation because they no
longer exist in the data model of the IED.
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If these points were referenced in another application, they will no longer be
available to that application.

2025-01-15 11:05:24.7475 - WARN:

2025-01-15 11:05:24.7475 - WARN: HomeDirectory=S000003,Point ID=358,Point
Name:TESTDEVICE_GOlTESTLD/GGIO4 .AnIn4.instMag.f[MX],Point Reference=,Point
Type=AnalogInput

2025-01-15 11:05:24.7475 - WARN: HomeDirectory=S000003,Point ID=359, Point
Name=TESTDEVICE GO1lTESTLD/GGIO4.AnInd.mag.f[MX],Point Reference=,Point Type=AnalogInput

9. If the previous configuration has points not mapped (unselected in the tree), and if any of the unmapped points
changed or were deleted in the new SCL file: the re-import log will not indicate this, because there is no impact on the
configured MCP. Same applies for new (added) data.

10. DSAS re-import should not be perceived as an SCL compare tool.
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DS Agile Studio - Frequently Asked Questions

Q:
A:

Is all SGConfig functionality included in DS Agile Studio?

Yes, except for the D2x Classic Editor. DS Agile Studio includes the D2x Advanced Editor, which provides additional
functionality (including sorting, searching, etc).

Can DS Agile Studio configure all D2x products that could be configured in ConfigPro and SGConfig?
Yes. This includes legacy and obsolete products, such as D20ME, D20M++, D10, etc.

Are configurations created in SGConfig, ConfigPro and earlier versions of DS Agile Studio compatible with DS Agile
Studio 5.1?

Yes.

e Existing archives of configurations created using earlier versions of DS Agile Studio can be restored into DS Agile Studio
5.1.

e Existing configurations created using any version of ConfigPro can be migrated into DS Agile Studio using the Migration
Wizard.

e Existing archives of configurations created using any version of SGConfig can be restored into DS Agile Studio. Change
the file filter in the bottom right corner of the File Open dialog to view Legacy Archives.

)
Legacy Archives (*.7zip;*.project.D57zip)

e Existing configurations in an SGConfig 10.x or SGConfig 11.x Repository can be Migrated into DS Agile Studio if version
of SGConfig is installed on that computer and has the repository loaded. The repository can be imported using the
“Migrate SGConfig Local Repository” option under the File menu.

e SGConfig Repository archives cannot be imported into DS Agile Studio.

Can DS Agile Studio be installed on the same computer as SGConfig?

Yes.

Can a configuration built in DS Agile Studio v5.1 be used in earlier versions of software?

Partially. The design of DS Agile Studio is slightly different from that of SGConfig. While configurations built in earlier
versions of software, configurations built in DS Agile Studio v5.1 have the following restrictions:

e DS Agile Studio v5.1 can be restored in DS Agile Studio v5.x, although any new functionality would obviously not be
there.

e DS Agile Studio v5.x configurations cannot be restored in DS Agile Studio v4.x or previous.
e DS Agile Studio configurations cannot be restored in SGConfig.
e DS Agile Studio configurations cannot be restored in ConfigPro.
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Q: | have a new PC with DS Agile Studio (no SGConfig). My old PC has SGConfig (no DS Agile Studio). How do | transfer all
my projects from old PC to new one?

A: Option 1 (recommended):
e Onthe old PC:

1. Install DS Agile Studio and then start it.

2. Import the projects in the SGConfig local repository into DS Agile Studio using the File = "Migrate SGConfig
Local Repository" option.

3. Create an archive of the SGConfig local repository using the File > Archive > Local Repository > Save
option.
4. Transfer the resulting archive to the new PC.
e On the new PC:

1. Start DS Agile Studio.
2. Restore the local repository archive using the File > Archive - Local Repository > Restore option.

B: Option 2:
e Onthe old PC:

1. Use SGConfig to create project archives (one project at a time).
2. Copy the resulting archive files to the new PC.

e Onthe new PC:

1. Run DS Agile Studio.
2. Use the File > Archive > Project > Restore option to import the project archives (one archive at a time).
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Additional Information
For more detailed information on the DS Agile Studio v5.1 release, see:
e The DS Agile Studio 5.1 Release Notes contained in the DS Agile Studio tool.

e The What's New topic in the DS Agile Studio Online Help.

e Visit GE Vernova Substation Automation technical support website for software updates:
http://sc.ge.com/*SASTechSupport

Product Support

If you need help with any aspect of your GE Vernova Grid Solutions product, you can:
e Access the GE Vernova Grid Solutions Web site
e Search the GE Vernova Technical Support library
e Contact Technical Support

GE Vernova Grid Solutions Web Site

The GE Vernova Grid Solutions Web site provides fast access to technical information, such as manuals and release notes.
Visit us on the Web at: https://www.gevernova.com/grid-solutions/
Subscribe for Product Updates:

([ sop W concrus

Register / Sign In

GE Vernova Technical Support Library

This site serves as a document repository for post-sales requests. To get access to the Technical Support Web site, go to:
http://sc.ge.com/*SASTechSupport

Contact Technical Support

For questions or further product support, please contact GE Vernova’s Grid Automation support team 24/7 using:

Region E-mail Telephone
Global Contact Centre ga.support@GE.com +44 1785 250070
Central and East Asia and Pacific ga.supportCEAP@GE.com +61 414 730 964
India ga.supportIND@GE.com +91 44 22648000
Middle East, North Africa and Turkey ga.supportMENAT®@GE.com | +971 42929467
Europe, Russia, CIS and Sub-Saharan Africa ga.supportERCIS@GE.com +34 94 4858854
North America ga.supportNAM @ GE.com +1 877 605 6777
Latin America ga.supportLAM@GE.com +55 11 36187308
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Copyright Notice
© 2025, GE Vernova and/or its affiliates. All rights reserved.

Trademark Notice

GE and the GE monogram are trademarks of General Electric Company used under trademark license.

Document Revision History

Version | Revision | Date Author Change Description

5.10 0 Jan 17, 2025 D. Morris Initial Release for DSAS v5.1
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